Version 2.1 High DPI scaling broken?
  • After upgrade from version 2.0 to 2.1 UI is corrupt, beyond usability on my Surface Pro 3 tablet.


    Anyone else having similar issues?
    Uninstalling and re-installing from scratch, did not help either...
  • Yes, Yes, Yes! Mine looks just like that, I was going to post a picture but no reason, mine is identical.

    It happened right after the upgrade from 2.0 to 2.1.   I tried uninstalling and re-installing but nothing. I'm a bit ticked now because I have quite a lot in mine and I don't want to lose all the stuff I've already paid for.

    I loaded mine onto my i7 16gb Laptop running Windows 8.1. I tried to run it in Windows 7 & 8 mode and it still is corrupt. Please fix it.

    Thanks
  • Well, I tried with my external display as well, unfortunately it is rather "high DPI" too, with a resolution 2560x1440, same issue.

    OS is standard Windows 8.1 Pro, in case if that matters.

    It would be interesting to know, if issue occurs with more regular resolutions 1366x768 or 1920x1080(1200) or is it only high DPI specific...
  • I started at 1920x1080 and stepped down in increments that my Dell Laptop let me and even got into bios to get all the way down to 600x400. Nothing changes. The login screen that says "Stagelight" works like a charm, looks perfectly but the second it gets into the actual program, its missing horizontal portions of the display. It sure does seem like this would have been identified prior to the release of 2.1. 




  • OK, then it is not actually DPI issue, but GUI seems to be just simply and completely broken in version 2.1

    Hopefully they will fix it soon... :)


  • You are correct, it's not a DPI issue, I figured a workaround for the time being. I went back to the old upgrade to 2.0 and ran it. It was very odd because it loaded and then it showed that it was starting "Stagelight". BUT, when it started, there was this screen that came up that stated that there was an upgrade to "Stagelight" and there wasn't anything you could do, you just had to let it install... I was hoping that it was going to install the 2.1 but it didn't but at least it did reload the 2.0 and its running now. I figure they will fix it and at least I can used this 2.0 for now.
  • C://Program Files (x86)/ is for 32-bit stuff actually and C://Program Files/ for 64-bit stuff if you are using x64 version of Windows... ;)

    For 32-bit windows there is no separate C://Program Files (x86)/ directory, so you can actually take it simply as this, that C://Program Files/ is always for "native" applications for OS architecture.

    So everything is correct in this case.

    Actually you can write the whole program as 32-bit for 64-bit OS, only thing that always have to be 64-bit are drivers (Drivers have to be OS native) , in this case StagelightAsio64.dll is Stagelight own ASIO audio driver library. And as you obviosly are using 64-bit (x64) OS, as you have 16GB of RAM (32-bit OS can only index up to 4GB, plus it will have to adress hardware aswell, so you are left approx 3-3,5GB usable RAM), hence the driver dll library is 64-bit aswell...

  • Ha, I've thought it was the other way for several years now. 



    Thank you... .
  • Hello,

    This is being caused by a Open GL driver issue. Please take a look at this FAQ thread for steps ot solve the issue: 

  • Yep, disabling OpenGL via options.xml definately helps on Surface Pro 3.

    Just a side note, my options.xml file did not have that line present, so I had to add it manually, maybe that should be included in FAQ as well.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!